Welcome! Log In Create A New Profile
Celebrating 10 years of PedrosBoard!
Tire Rack: Revolutionizing tire buying since 1979.
Buying through this link, gets PB a donation.

Expect the best, and accept no substitute.
I've developed a creak in the front suspension of my 07 cayman. If I just stand next to it and push on the front end, it's plenty audible, especially when hot or warm. I read somewhere that it could be the sway bar bushings. Anyone have experience with that? Can I just spray some lubricant on them, or do I need to replace them, or the whole bar?

Thanks for ideas...

Steve
and none are open so all spraying any lube on these would do is just have the lube act as a dirt magnet.

You need or you need to have someone check the suspension bushings for any signs of problems. A bushing might have failed a seal or dust boot failed and if so replacement is called for.

If you find nothing wrong and if you can't live with the noise then replacement I think is your only recourse. You can of course speak to your tech in case he's aware of some other way to address the noise. I don't think lubrication is an option but a tech might have another opinion.
I laid down and took a look at the suspension, turned out the boot had torn on the transverse control arm ball joint. It was pretty easy to diagnose since it had spewed it's grease out of the hole. It's worth a check. If the problem has progressed to audible levels, it might be easy to see. If you're not as lucky as me, you can always have a friend press down on your fender while you feel around the suspension. You'll notice that you'll feel the vibrations of the creaking sound and they'll become more pronounced as you close in on the source location.

Best of luck!

Jay
Creaking can come from the lower control arm ball joint. The fix is to prick a small hole in the ball joint boot and spray WD40 into the boot. It worked on mine, but not for very long, couple of months at most.
I went years before replacing that control arm doing a similar thing. Although, I used grease. It lasted much longer. First I used an aerosol lithium grease (since it had a hose I could shove in the hole) then I got a grease injector needle that just fits into the end of my grease gun. That's a really useful addition to the tool cabinet!

Something like this

Jay
The guy does the WD40 fix that you describe, and it seems to work. I'm going to try the grease injection instead. Hope it lasts longer.

[www.youtube.com]
I had the squeak on the rear driver's side.
I followed the instructions in that video (I used a higher quality lube) and the squeak never went away.
Any know around how much it would cost to have the part replaced at the dealers?
buying a syringe attachment for your grease gun and injecting moly (or any really good) grease, then working it around. Seal the hole with silicone.

Grant

Grant

gee-lenahan-at-gee-mail-dot-com
How many miles?
grant - 7 years ago
Its seems quite early to have that problem.... the noise could be many places:

1. a shock (less likely, requires replacement)
2. sway bar bushings (common, must either replace or remove and grease, replace - neither all that hard
3. ball joint (unlikely, integral to control arm, big-ish job)
4. control arm rubber bushings - integral to control arms

Spraying stuff on the sway bar does nothing, unless you open up the clamps holding them in place so the lubricant can get in.

Grant

Grant

gee-lenahan-at-gee-mail-dot-com
And should that be the case, I believe they come in two thicknesses, and need to be replaced per the original's.
ShockBearingSearchResults
I doubt it would be the source of the noise. The bearing is still a possibility.
Thanks all, for the helpful tips.

It's become loud enough now that I'm going to switch to my backup car (boxster!) until I fix it, either myself or at my local indy.
[scontent-a-sjc.xx.fbcdn.net]

So far so good, but it'll be a while before I'm confident that I have or haven't fixed it. If this works, it's an awesome fix for costing just $40 worth of interesting new additions to the toolbox.
Noises seem to have stopped after about the first 20 miles or so of driving, when I guess the grease was working into things. Thrilled to have this sorted.

For anyone else trying, I'd suggest going easy on the amount of grease. I put too much at first and a fair amount squished back out of the hole I'd made. It was easy to clean it up, but I was then reluctant to seal the hole since I didn't want anything to rupture. The hole is tiny enough though (hard to see afterward). Sealing might not even be necessary. If I do it again, I'll start with just one to three squeezes of the grease gun trigger, then test drive for a while. I expect that would be plenty.
What kind of grease gun is that? What kind of grease did you use?
Do you have to take the wheel off?
here's what i used. Oh and yes, I took the wheels off. That might not be necessary, but it makes it easier to see what's what.

grease gun:
[www.amazon.com]

grease: (this is a lifetime supply, way more than is needed)
[www.amazon.com]

injector needle: (frighteningly sharp)
[www.amazon.com]

silicone sealant: (didn't really use)
[www.amazon.com]



Edited 1 time(s). Last edit at 08/01/2014 05:58PM by Steve (Morro Bay). (view changes)
Sorry, only registered users may post in this forum.

Click here to login