Welcome! Log In Create A New Profile

Re: We are in the same boat. Just yesterday afternoon...

Tire Rack: Your performance experts for tires and wheels
Buying through this link, gets PB a donation.

Products for your Boxster, Cayman and Carrera.
2001 boxster s. 44k miles. Throws both codes. I've cleaned MAF, replaced both O2 sensors, checked AOS, there isn't an exhaust leak, did the oil cap check and it still throws both codes. The codes indicate passenger side, I swapped the sides of the O2 sensors and codes tripped again saying passenger side, so clearly O2 sensors are fine. Checked trim levels, functioning normal. Dealer also evaluated and says there is no reason the codes should be triggering. Then it occurred to me tonight, I've been using non oxygenated gas for quite some time. Is there any chance that could be the culprit?
I don't think the gas would cause the codes.
I had a similar problem with my '00 S at 40k miles. Replaced the MAF sensor and the problem went away.

Ed B
Possible culprits
Boxsterra - 2 months ago
Leak in exhaust system
Leak in intake system
Fuel delivery restriction (typically fuel injector contamination)

I would try running a bottle or two (sequentially) of Techron Fuel System cleaner -- not Fuel Injector Cleaner -- through the system.
my 2002 Boxster triggered its CEL and the error code was P1128.

This is I think the 3rd event over the last month or more.

I date logged the engine and the error didn't happen. I stopped data logging and the error happens. I can find no possible explanation for the error in my car's case. The AOS was replaced back in mid-2014. OIl cap was replaced not too many months ago and is not leaking. I checked my records and the O2 sensors were replaced back in 2014 as well, at around 305K miles. (There was a p0134 error code.)

The only common factor I note is the error appears when it is hot -- it was 102F yesterday -- and I was driving in this heat coming back from lunch at something past 2pm when the CEL came on.

In your car's case I'm with Ed. The gasoline has nothing to do with the error.

Boxsterra offers the official possible faults. The Techron suggestion is a good one. (After a tank or two of Chevron Supreme my Boxster engine ran noticeably better after I switched from Shell V-Power to Chevron Supreme with Techron. But the P1128 has appeared with Chevron gasoline and this last error code appeared with Shell V-Power. (The local Chevron station I have been using has been closed and in just a day or two torn down. There are no nearby price competitive Chevron staitons so I'm back to using Shell mostly unless I want to fill up at a Chevron station on the way to work.)

Anhyhow, try the Techron. It is about all one can do without getting his hands dirty. And really I have no idea of what you should do to get your hands dirty.
Interestingly, I did try the techron many miles ago and the light went off, BUT returned 500 miles later. I've tried everything suggested here, but nothing works - hence the mystery. The car seems to be running perfectly and the dealer says there are no leaks, exhaust, intake, or otherwise. They say to keep driving it and that it won't the car. All the data looks fine, trim level etc. The only thing I can think of is the non oxy gas, if that's not it I have no idea what else it could be.
Quote
John from MN
Interestingly, I did try the techron many miles ago and the light went off, BUT returned 500 miles later. I've tried everything suggested here, but nothing works - hence the mystery. The car seems to be running perfectly and the dealer says there are no leaks, exhaust, intake, or otherwise. They say to keep driving it and that it won't the car. All the data looks fine, trim level etc. The only thing I can think of is the non oxy gas, if that's not it I have no idea what else it could be.

The CEL can go off on its own after so many warm up cycles with the error condition absent.

The CEL can remain off to the point that whatever was done appears to have fixed the cause of the CEL coming only to just when one begins to relax and breathe normally while driving the car the CEL comes back on again.

Regarding gasoline I have no experience with non-oxygenated gasoline, at least no recent experience. CA gasoline has been treated with ethanol now for a long time. I may have filled up the gasoline tank with non-oxygenated gasoline on one of my road trips but I don't recall specifically finding non-oxygenated gasoline or seeking it out.

But there is the saying the last thing touched is the first thing suspected. The switch in gasoline may (may...) be a factor. But about all I could advise would be to switch back (if possible) to what gasoline you were using before the CEL made an appearance and see if the CEL remains dark.

I know when I switched from discount premium gasoline to Shell V-Power a P0430 error code appeared much less frequently even though everything else -- but the gasoline -- stayed the same.

However, the P0430 error albeit less frequently still appeared. The Shell gasoline helped in some way but the cure was to replace the bad (loose brick) converter.

Also, as I have commented on before when I switched from Shell V-Power to Chevron Supreme the Boxster engine ran noticeably better after a tank or two and this I attribute to the detergent qualities of the Techron in Chevron gasoline.

My point is gasoline can make a difference. It is up to you if you want to experiment and see if consistently running a different gasoline helps. The problem is as I touched upon above the error code can stay away until one believes what he has done is the fix only to be faced with a bright CEL.

Might add I queried the car for its freeze frame data this AM. The engine was in closed loop mode. Idling. Coolant temperature was 205F I don't recall what intake air temperature was now. The other readings were all normal. What was abnormal was the long term fuel trims. LT1 was -10.9%. LT2 was -9.4%. Short term fuel trims looked were not as negative: ST1 was -1.6%. ST2 was -2.3%; but it appears the DME was still trying to remove fuel even with the long term trims as negative as they were.

Might add that given how negative both long term fuel trims were the 2nd bank was just a bit behind the 1st bank in generating a P1130 code. This suggests a common failure mode at least in the case of my Boxster engine.

For the negative long term fuel trims: Running too rich – High negative fuel trim corrections can be caused by MAF sensor problems, high fuel pressure, leaking fuel pressure regulator diaphragm, faulty evaporative emissions components, leaking injectors, defective O2 sensors, exhaust leaks/pinholes before the O2 sensor, coolant temp sensor problems, and base engine issues such as low compression and incorrect camshaft timing.

I'll speak with the tech when I pick up the Boxster (after its left front tire replaced) and see if he has anything more to add. Otherwise I'm just going to drive the car as long as it runs ok, doesn't manifest any untoward behavior. At some point I guess the base cause of the P1128 (and possibly P1130) error code will be more apparent.
in MN, Non - Oxy is available mostly for boats, classic cars, and small engines, but it's tougher to find. I'm lucky in that I have 3 stations near me that carry it. I've been using it in the Boxster because I feel it's better for the car than ethanol. I can find the ethanol blend in Top Tier and boost the octane to 92, non top Tier I can find at 93. But it sounds like the consensus is that the gas isn't the culprit. Based upon what you and Boxstera have mentioned, I have tired the Techron, but I haven't used a second bottle. I'll start with the second bottle. If that doesn't work I'll try a few tanks of regular ethanol Top Tier to see if that impacts it. If that doesn't work, I'll go back to cleaning the MAF again - is it possible the MAF needs to be replaced entirely at 44K?

Also tomorrow, I'll take Pedro's advice and check the fuel pressure, although historically, the fuel trim levels have checked out fine.

Finally, I used to on PPBB and it's great to see so many familiar names and it's also great to see you are all just as helpful as before. I need to spend more time here.

Thanks for your help!
Quote
John from MN
in MN, Non - Oxy is available mostly for boats, classic cars, and small engines, but it's tougher to find. I'm lucky in that I have 3 stations near me that carry it. I've been using it in the Boxster because I feel it's better for the car than ethanol. I can find the ethanol blend in Top Tier and boost the octane to 92, non top Tier I can find at 93. But it sounds like the consensus is that the gas isn't the culprit. Based upon what you and Boxstera have mentioned, I have tired the Techron, but I haven't used a second bottle. I'll start with the second bottle. If that doesn't work I'll try a few tanks of regular ethanol Top Tier to see if that impacts it. If that doesn't work, I'll go back to cleaning the MAF again - is it possible the MAF needs to be replaced entirely at 44K?

Also tomorrow, I'll take Pedro's advice and check the fuel pressure, although historically, the fuel trim levels have checked out fine.

Finally, I used to on PPBB and it's great to see so many familiar names and it's also great to see you are all just as helpful as before. I need to spend more time here.

Thanks for your help!

Ethanol treated gasoline, while it is not as good for the environment as the EPA and state governent agencies would have you believe, is not *bad* for the car.

I would be a bit concerned about your using the non-oxygenated gasoline because it could be stale. Premium gasoline is reported to go off sooner and what is lost is the octane and I'm thinking the non-oxygenated gasoline fuel pump receives less business and the gasoline is on average older than the gasoline in the other tanks.

There is another concern about this non-oxygenated gasoline and that is I *hope* it doesn't have any lead in it.

However, apparently the problem appeared *after* you switched away from non-oxygenated gasoline so my concerns are unwarranted.

I can tell you with my limited experience with my 996 Turbo -- on a road trip and passng through Wyoming -- if you have ready access to gasoline above 91 octane, with or without ethanol and it is price competitive with lower grades of octane gasoline I'd recommend you use the highest octane of gasoline you can. When I had a chance to run 93 octane in my Turbo the engine's reaction was quite an eye opener. The engine *loved* the 93 octane gasoline even though I was driving in an area of higher elevation where normally an engine's octane requirements decrease due to the higher elevation.

But of course you need to find and fix the cause of the P1128.

Oh there could be a bit of confusion.

In my previous post I mentioned the previous day's P1128 error and the large negative (approx. -10.0) values. This is an indication the DME is *removing* fuel due to an overly rich condition. Yes most references regarding P1128 have something like this: "Fuel/air mixture is so lean that the control is up to the enrichment limit."

Thus most take the P1128 error to be due to an air leak, inadaquate fuel supply/pressure problem. However, another Porsche reference I have indicated there are two different variations.

Here is a cut/paste:

360 Oxygen Sensing Adaptation, Idle Range, Bank 1 - Below Limit
Diagnosis conditions
• Oxygen sensing system active
• Time elapsed after engine start-up: 250 to 350 seconds (USA)
• Time elapsed after engine start-up: 302 to 402 seconds (RoW)
• Engine temperature greater than 60 °C
Possible fault cause
♦ Incorrect signal from MAF sensor
♦ Fuel pressure too high
♦ Fuel injector leaking
♦ EVAP canister purge valve open


and

360 Oxygen Sensing Adaptation, Idle Range, Bank 1 - Above Limit
Diagnosis conditions
• Oxygen sensing system active
• Time elapsed after engine start-up: 250 to 350 seconds (USA)
• Time elapsed after engine start-up: 302 to 402 seconds (RoW)
• Engine temperature greater than 60 °C
Possible fault cause
♦ Incorrect signal from MAF sensor
♦ Intake air system leaking
♦ Fuel pressure too low
♦ Volume supply of fuel pump too low
♦ Fuel injectors fouled


Both P1128 errors above have the same secondary error code: "360". In my reference there is no explanation for this but there are two sections which cover both the the essentially too little fuel and the too much fuel variations.

Based on the freeze frame data from my car's DME in my car's case the P1128 error is the "first" one, in which for some reason too much fuel is being supplied and the DME is having to remove fuel.
The MAF seems the most obvious culprit. I am a little surprised the dealer has not checked that.

To satisfy your self, either replace - it is a very easy job. Or find a known good one and swap.
Quote
JMstamford,ct
The MAF seems the most obvious culprit. I am a little surprised the dealer has not checked that.

To satisfy your self, either replace - it is a very easy job. Or find a known good one and swap.

It is a rather easy job but the MAF isn't cheap. Still, if the MAF is bad it is bad.

The CEL came on again yesterday and sure enough P1128 again. This time the long term trims were even "worse" than the other day. One was at -11.9% the other at almost -10.0%. As I watched the short term trims were in the range of +5% so the DME was desperately trying to add fuel. For the fueling to experience such a rapid change suggests a MAF problem. Intake air temperature and coolant temperatures were reasonable and as I expected them to be. (For example, I like to see the intake air temperature about ambient though with the Boxster my experience is it will not be ambient but be some 20F+ degrees hotter if the car is stationary for any length of time with a hot engine.)

As reluctant as I am to throw parts at a problem, I'm seriously considering replacing the MAF. The MAF is original, though it got an approx. 100K mile "vacation" when I replaced it with a new MAF when the real problem proved to be a leaking oil filler tube cap. I have checked the cap and it is not leaking. The replacement MAF started acting up and I fell back to the original MAF which worked just fine.

But the MAF in there now is original and has been in service around 200K+ miles so I think I have gotten my money's worth.
Coolent temp: 215.6
Fuel Trim LT1: 5.47%
Fuel Trim LT2: 4.69%
Fuel Trim ST1: -4.69%
Fuel Trim ST2: -1.56%

I must have been idling, RPMs 680 and speed zero
Quote
John from MN
Coolent temp: 215.6
Fuel Trim LT1: 5.47%
Fuel Trim LT2: 4.69%
Fuel Trim ST1: -4.69%
Fuel Trim ST2: -1.56%

I must have been idling, RPMs 680 and speed zero

My engine's idle speed was 680 RPMs too. The error code is specifically for the idle operating range of the engine so a 680 RPM reading certainly falls into the idle range.

My engine's coolant temperature was 205F, but I don't think the difference significant.

But I note the long term fuel trims are positive while the ones from my car were negative. This tends to reinforce what I just posted regarding two variations of the P1128 error condition. One that is due to the engine running too lean which is what the positive long term fuel trim numbers suggest occurred with your engine and too rich which is what the negative long term fuel trim numbers suggest occurred with my engine.
TL;DR Try swapping your MAF with someone else's. If it fixes the problem, you know what to buy. Don't spend over $200 for a replacement.

Here are some fuel trim concepts that may help:
- Positive means it's adding fuel (you'd think it would mean it's "trimming fuel" but that would be too easy to remember)
- Short-term fuel trims are additive with long-term ones. So if you have positive LT and an equal negative ST then your car is running with no net trim.
- Not all leaks are constant. Some depend on the heat of the car, the outside temperature, the pressure/vacuum of the exhaust/intake.
- Fuel trims will vary under normal circumstances. This is because trimming is a reactive adaptation (O2 sensors feeding back mixture data post-combustion)

You have a lean condition (that is the meaning of P1128/P1130). This can be caused by:
- MAF is reporting the wrong number (common Boxster problem)
- Intake leak is letting unmetered air into the system
- Leak in exhaust before O2 sensor makes the car think it's running leaner than it actually is
- Fuel system isn't delivering enough fuel (fuel pump / fuel injectors / fuel lines are faulty/clogged)

The reason I suggested using Techron was not that it was most likely to solve the problem but because it is super easy.

If you want to know if the problem is the MAF, then look at the MAF air flow values at idle and 3000 rpm.

Idle: 12-24 kg/h
3000 rpm: 50-80 kg/h

There are many common intake leaks on the Boxster, including the oil filler tube, dipstick tube, AOS, and anything that was recently touched during service.
Quote
Boxsterra
TL;DR Try swapping your MAF with someone else's. If it fixes the problem, you know what to buy. Don't spend over $200 for a replacement.

Here are some fuel trim concepts that may help:
- Positive means it's adding fuel (you'd think it would mean it's "trimming fuel" but that would be too easy to remember)
- Short-term fuel trims are additive with long-term ones. So if you have positive LT and an equal negative ST then your car is running with no net trim.
- Not all leaks are constant. Some depend on the heat of the car, the outside temperature, the pressure/vacuum of the exhaust/intake.
- Fuel trims will vary under normal circumstances. This is because trimming is a reactive adaptation (O2 sensors feeding back mixture data post-combustion)

You have a lean condition (that is the meaning of P1128/P1130). This can be caused by:
- MAF is reporting the wrong number (common Boxster problem)
- Intake leak is letting unmetered air into the system
- Leak in exhaust before O2 sensor makes the car think it's running leaner than it actually is
- Fuel system isn't delivering enough fuel (fuel pump / fuel injectors / fuel lines are faulty/clogged)

The reason I suggested using Techron was not that it was most likely to solve the problem but because it is super easy.

If you want to know if the problem is the MAF, then look at the MAF air flow values at idle and 3000 rpm.

Idle: 12-24 kg/h
3000 rpm: 50-80 kg/h

There are many common intake leaks on the Boxster, including the oil filler tube, dipstick tube, AOS, and anything that was recently touched during service.

Not normal based on my info and observation. +/- 10% is getting close to (is in) CEL territory. To have a short term fuel trim that appears it wants to remove nearly all or all of the -4.69 long term fuel tirm adaptation is not a sign of normal.

The MAF is not listed as a possible cause of a P1128/P1130 in any of my references.
the MAF reading at idle varied between 0 - 1 inch with the majority of the readings being .5 inches. At 3000 RPM, the readings didn't appear, once I let it idle again, the previous readings were reported again. Reading the MAF readings is new to me so I don't know what the inches are referencing or even if I did it correctly, which I'm guessing I didn't otherwise why would the MAF readings disappear at 3000 rpm? I did clean the MAF again and didn't see any signs of intake leaks. I'm not sure what else to do at this point if the light comes back on except to replace the MAF. At this point, I'll finish this tank of gas, add the second bottle of techron and try a few tanks of oxygenated gas (vs the non oxy I've been using).

I really appreciate all the help, you guys are awesome and I've learned a lot!
These values can be read at any engine speed using an OBD2 reader. I personally use a bluetooth plug connected to an Android phone running Torque Pro (but Torque Free also reads this stuff).
I don't know anything about MAF readings but that seems odd. Am I interpreting it correctly and is that a sign of a bad MAF sensor?
Which means that either the MAF is bad or the wiring from the DME to the MAF is bad.

With MAF disconnected:

Continuity
DME Pin 17 → MAF pin 5 (0-5 Ω)
DME Pin 17 → ground (should not be connected)

Voltage
DME Pin 17 ↔ ground, ignition on (should be 0V)

With MAF connected, ignition on (car not running):

MAF pin 5 ↔ MAF pin 3 - should be 1.8v (indicating no flow)
the lesser known brand at $121? (not sure if I'm allowed to mention brands here) smiling smiley
You indicate the car is 16 years old. That means 2000-01.

There were several changes updates to the MAF around that time. If you get the wrong one, the DME needs to be updated.
When you take the old one out, look at the Bosch part number.

I am doing this by memory - but as I recall, there were 3 batches -- the part numbers ended in 123, 124 or 125. So, the numbers were 996.xxx.xxx.123 (again, as I recall.)
Just make sure that YOUR new MAF has the same number as the old MAF or you will need to reflash the DME. At the time, the MAF plus reflash was about $1K at the dealer.

Also be sure you are getting a new MAF. There were recycled units out there at one point.
So, I would pay the extra to have a guaranteed known new unit. I think I got mine from one of the know dealers or pelican.
If it is Bosch, then it's fine. Otherwise, I wouldn't do it.

FWIW, you can buy the Bosch sensor at AutoHausAz for less than $238.
18-24confused smiley g/s at 3000 rpm. Which sounds about right and brings me back to scratching my head. confused smiley
The long term/short term fuel trims were even "worse" than before. This time LTFTs 1 and 2 were -12.5% and -8.6%.

STFTs 1 and 2 were -2.3% and -2.3%. The DME was still trying to remove fuel even with the long term fuel trims in negative territory.

I'm tempted to throw a new MAF at my car's behavior. The MAF is original but had an approx. 100K mile "break" but still it has worked for nearly 200K miles.

In fact rather than a new MAF I'm tempted to try a used one. Parts Heaven is near where I work and I might see what it has to offer in the way of a used MAF and at what price. The only "problem" is I should probably have the part # off the MAF currently in the car so the clerk can pull one with the same part # off the shelf. This means I have to expose the engine and get the part # from the MAF and then button up the car and get the replacement MAF and then expose the engine again and remove the old MAF and install the used one.

This is made a bit more difficult in that it appears the replacement top is not as good about staying in the "service" position as the factory top. The replacement top keeps flopping the rear window folded section down and this really annoys me.
It's unambiguous which part # to use unless you happen to have an early 2000 MY car.

See here: [sites.google.com]
Weird. After the first tankful and the first MAF cleaning I reset the CEL. When it came back on, I left it on and again treated the next tank of gas and cleaned the MAF again. Today, while driving, the same twisty roads with the same aggressiveness, the light magically went off when the tank was nearly empty. It had been about 400 miles since the light had went on for the second time. I suspect the CEL will return, but we'll see.
The CEL went dark because the DME didn't detect the error condition again after so many engine warm up cycles. This is just another sign the error condition is intermittent.

I've got no more news on my P1128. It came back on a milder day just after I thought it was only a hot day only problem. It hasn't come back in a while and I've done nothing different.

Gettting close to time to take the car in for its 315K mile oil/filter service. If the tech is not too busy and if I have the time I'll speak to him about the error and see what he recommends. If I speak to him I'll share.
... (most likely) an intake leak downstream of the MAF.
With the car idling, spray engine starter fluid or carb cleaner or MAF cleaner at every point where there could be a leak on the intake.
Start around the throttle body, then around the intake tee and it's rubber sleeves. Also check the oil fill tube and the AOS breather tube.
Make sure all of the vacuum lines are connected.

In lieu of an air leak, the second possibility would be the MAF. Clean the MAF and reset the code. Drive the car and see if the codes come back. It could take up to 100 miles.

Finally I would consider the fuel injectors (or fuel pump). Measure the gas pressure to see if its nominal.

Basically what those codes are saying is that the O2 sensors are reading too much oxygen at the exhaust.
If you have an air leak after the MAF that explains it.
If the MAF is reading lower that it should, that explains it.
If the injectors are providing less gas that expected, that explains it.

Happy Boxstering,
Pedro

Pedro Bonilla 1998 Boxster 986 - 280,000+ miles: http://www.PedrosGarage.com
PCA National Club Racing Scrutineer - PCA National HPDE Instructor - PCA Technical Committee (Boxster/Cayman)

Racecar spelled backwards is Racecar
"Racing is life. Anything before or after is just waiting" ... Steve McQueen as Michael Delaney in "LeMans"
"If you wait, all that happens is that you get older"... Mario Andretti
"Being second is to be the first of the ones who lose" ... Ayrton Senna
In my case I took a propane torch and opened it up in a WELL VENTILATED area. moved around the intake listening for increased RPM's - None.

I swapped the MAF - no issues since.
should be triggering. They did check for leaks and didn't find any, said the injectors were fine, and weren't concerned with the MAF - although I had just cleaned it prior to them seeing it. Their explanation was that it was either that I didn't use the Porsche Brand O2 sensors or that I just wasn't driving it hard enough. I thought their explanation was weak, but felt good that they weren't trying to gouge me. But then again, I am a bit concerned that they didn't put anywhere near the effort into diagnosing and troubleshooting the issue as all of the people in this thread have done. You guys are a wealth of knowledge. Everything I'm hearing here, especially Boxsterra's explanation is pointing to a bad MAF. The car does only have 44K miles on it, but the part is 16 years old and it can't last forever, right? I'm leaning toward just replacing the MAF at this point and seeing if that does the trick.
is the car running poorly?

I don't know pcodes off by heart, but a former poster/former neigbor here (I think his handle was Alcantera) had misc pcodes linked to fuel/air mixtures... I am going by foggy memory here, but I think he *may* have had a lumpy idle as well.... Turns out, there is a gasket by the air filter box that was loose, once it was back in place, all was well... I know it's before the MAF, but it caused some weird metering issues for him.
Sorry, only registered users may post in this forum.

Click here to login