Welcome! Log In Create A New Profile
Celebrating 10 years of PedrosBoard!
Tire Rack: Revolutionizing tire buying since 1979.
Buying through this link, gets PB a donation.

Expect the best, and accept no substitute.
shifter
Michael SYS Driver - 2 months ago
Hello All, I have a B&M short shifter that no longer wants to work well. Reverse is a pain to get into and when it is really hard to engage reverse I have to hit really swing at the lever to make it go over to 3rd. I was looking at either a cheap no name from that place in south america lol, or? How is the Schnell shifter? Anyone have any recommendations?

Thanks
Re: shifter
jlegelis - 2 months ago
Are you sure it's not the cables that need to be readjusted due to stretching or age?
Yes I had a shop look at it and they tried adjusting it.
Re: shifter
frogster - 2 months ago
i installed the B&M many years ago. i too think it's probably the cables. there's not much that can go wrong with the shifter mechanism. i would check for loose pieces on the shifter, either bushings or screws/nuts/bolts. if they're fine, then it has to be the cables. the short shift parts should last a lifetime. i know you said a shop took a look at it but i'd ask for a second opinion somewhere else.

--
MY 2000 S, Ocean Blue, Metropol Blue, Savanah Beige.
Bought June 2000 - Sold May 2010
DIY
Boxsterra - 2 months ago
I would get the $5 Porsche shifter alignment tool and have a go at it yourself. Or if you have any tech gatherings in your area, someone else can do it. I agree with frogster that the shop probably didn't do it right.

That said, as the linkage at the transmission wears, it gets sloppy, which means cable adjustment has to be more precise.
Re: DIY
Michael SYS Driver - 2 months ago
Just to give an update, I contacted Jamie, who used to be on Pedro's board in the beginning and asked him if he could look at it. He and his assistant looked at it and adjusted the cables and realigned a bracket (not to say it was quick, because it did take all morning). That was it, it shifts much easier into reverse and the 2nd to 3rd shift flows nicely now. I am quiet happy now, and have a much lower opinion on the shop that said they tried to adjust it and I said I needed a new shifter. Jamie did say if it was the linkage by the transmission I would need to take it to a shop.
--
MY 2000 S, Ocean Blue, Metropol Blue, Savanah Beige.
Bought June 2000 - Sold May 2010
Not a Porsche speciality shop but they do a lot of Porsches there as well as other high end european cars.
Replacing the linkage at the transmission is not hard at all. You unbolt the unit, pop two balls out of sockets, and reverse to install the new unit. Really, quite easy.

Here is a picture of the new linkage I installed on my car after about 185k miles





Edited 1 time(s). Last edit at 09/25/2021 04:25PM by Boxsterra. (view changes)
True, but
Boxsterra - 2 months ago
I was responding to the assessment from the person who adjusted the shifter that replacing the linkage had to be done by a shop.
The person that fixed my car is a stereo guy not really a mechanic. As a side note he does have 2 lotus' in his shop. An Exige and an Evora, I think.
Nice
Boxsterra - 2 months ago
I used to work on Lotuses. They're a lot more fun to drive than to fix.
@Boxsterra does the Porsche OEM alignment tool work with the B&M shifter... 've seen conflicting reports? I installed my B&M many years ago without the alignment tool (didn't know the tool even existed until this thread) and feel the shifter in need of adjustment so perhaps a nice fall project? Please LMK your experience.

-JohnL
Boston
2001 986S
Alas, no
Boxsterra - 2 months ago
Here is a good discussion of the different variations of the Porsche tool and alas, none of them seems to work with B&M

The purpose of the tool is to hold the shift lever in the center of the neutral position while you adjust the cables. You can do this without the tool but the tool makes it super simple.



Edited 1 time(s). Last edit at 10/05/2021 11:21AM by Boxsterra. (view changes)
Re: Alas, no
jlegelis - 1 month ago
@Boxsterra - thx for the link. so to confirm there's no service tool for aligning B&M?
but I'd be surprised if one didn't exist. Maybe shoot B&M an email?
more likely either:

1. worn/stretched cables, or
2. Lubrication of the ball/shifter (spray lubricant, work it in, WD40 is not a lubricant.

Grant

gee-lenahan-at-gee-mail-dot-com
Sorry, only registered users may post in this forum.

Click here to login