Welcome! Log In Create A New Profile
Celebrating 10 years of PedrosBoard!
Tire Rack: Revolutionizing tire buying since 1979.
Buying through this link, gets PB a donation.

Expect the best, and accept no substitute.
Hello Everyone, well here I go again with another problem. I was out today just driving around, stopped for some lunch but then when I got back in and tried to start it, it would crank and it would sound like it started but as soon as I let go of the key it would die. I had no check engine light and I had my odb reader with me and there was nothing on that. The electrical was fine because all of the lights and windows worked and the car was cranking. I seemed to me that maybe the fuel pump was stopping as soon as I let go of the key. It did sound as if it was firing and starting. I had just filled up the car as well as it had gas and I just had the oil changed. It is the shop now waiting to be worked on so... just want to know what the community thinks.
How old is the ignition switch?
I just replaced it a year or two ago. But it does crank and fire so...
... and I agree with mikefocke in first checking the ignition switch.
What model year is your car?

Happy Porsche'ing,
Pedro

Pedro Bonilla
1998 Boxster 986 - 299,000+ miles: [www.PedrosGarage.com]

PCA National Club Racing Scrutineer - PCA National HPDE Instructor - PCA Technical Committee (Boxster/Cayman)



Racecar spelled backwards is Racecar

"Racing is life. Anything before or after is just waiting" ... Steve McQueen as Michael Delaney in "LeMans"

"If you wait, all that happens is that you get older"... Mario Andretti

"Being second is to be the first of the ones who lose" ... Ayrton Senna

I'm thinking it's a M96, so my conjecture probably doesn't apply, but;
Your symptoms seem similar to ones my 9A1had, and it turned out to be a camshaft solenoid in both instances. The dealer caught an intermittent fault that apparently didn't register in the memory. The fix wasn't cheap, but it was the fix in each case.
Re: Bad fuel pump?
grant - 2 months ago
When you turn the key to "on" **but do not crank the motor**, do you hear a slight whir? That is the fuel pump. NO? I may not be working. Typically fuel pumps begin to make noise, then fail intermittently, as bad spots in the motor make themselves heard.

Agree that two other culprits are known and in fact more common:

1. Ignition switch ($10 electrical portion, shared with many Audis of the period,hard to access)
2. Crank position sensor

Only the 3rd has any prayer of throwing a code.

Grant

gee-lenahan-at-gee-mail-dot-com
Unfortunately, it is sitting at the shop, so I can not try some of the options. Well I hope it is the ignition switch. I agree about the switch being hard to access. I replaced it a few years ago and I had to get my wife to get her hands in there.

Thanks for your thoughts.
Grant

gee-lenahan-at-gee-mail-dot-com
The shop called and asked if I could bring a spare key to the shop because they were getting an antitheft code on the obd. Puzzled as to why I would get that I said I will bring it over. They tried the spare key and it started right up. He did it a few times just to make sure. I asked why would I have an antitheft code on my car when I was starting it with my key? He said if you push the lock button when you start the car it goes into anti theft mode. Huh? I have never heard of this. Has anyone else heard you can do this with the key? and why would they do that? Maybe if you get car jacked? He then said I should get a new key coded to the car because the car's computer now has an antitheft code associated with that key and he does not know if it would happen again. That seems a little over the top. Is this true what the shop told me? Has anyone heard of this "feature" before?

TIA
That can happen
Boxsterra - 2 months ago
if the solder joint between the key microswitch and the circuit board isn't continuous. The key sends an interrupted signal that the car detects as invalid. The first fix attempt should be to inspect and repair the solder joint because it is very quick and easy.
thanks, but what about he said I should get a new key because the old key is now "coded" as a bad key? and you have heard of the system going into antitheft mode?
I would still check the circuitry on the key board first since it only takes a minute to do. That said, this is from the service manual:

Radio transmitter outside lock-in range

If the transmitter is operated more than 256 times without reaching the associated receiver (e.g. vehicle outside range or vehicle battery disconnected), the vehicle will not recognise the radio transmitter the next time it is operated. If the number of operations is less than 1024, it is possible to perform re-synchronisation as described below:
— Switch on ignition with key and valid transponder.
— Switch off ignition.
— Remove ignition key from steering lock.
— Operate transmitter within 6 seconds after the key has been removed.
The lock-in range has now been reset to zero (as is the case with every recognised transmitter operation).
The post speaks to the transmitter not the receiver.

If the key was in your pocket with other stuff, the transmitter could have been depressed many times with walking or sitting or moving about.
Clearly that might be dependent on a number of other factors. But it is still possible.
Yes, and also
Boxsterra - 2 months ago
a single press may result in multiple "operations" if the connection is intermittent, as I previously theorized
soldering skills are begineer at best. I do know someone who does have soldering skills and this would be obvious and and easy fix? If not then I guess a new key coded from the dealer is the only other option?
When solder joints crack, the crack may not even be visible to the naked eye. In those cases, reflowing the solder (basically just melt it and let it reset) is standard procedure for a suspect joint.

In the case of the Boxster key, because the range generally sucks, people tend to instinctively mash the key and I have seen several keys where the microswitch is physically dislodged on one side from the board.

Regardless, anyone with even just ok soldering skills should be able to fix it. If you can't get the solder to stick, you're not using enough flux smiling smiley
Hey Stefan,

I have a problem with my original key as well.

1.Spare key works great
2 regular key opens and starts car mechanically (so "pill" is good?)
3. regular key remote does not work
4. regular key remote does flash LED

I did replace the key body & buttons since they had disintegrated. I thought that might be the issue.

If memory serves i did replace the microswitch too (soldered a new one on from the ebay kit)

Does this sound consistent to you and where is the offending solder joint or trace?

TIA!

Grant

Grant

gee-lenahan-at-gee-mail-dot-com
Answers
Boxsterra - 1 month ago
If the key starts the car then the pill is working.

Red arrows point to the possibly bad solder joints. This key head is from a Carrera GT but the circuit board is identical to the ones from early 2-button Boxster remotes.

... observations for others.

I did take a gamble an ordered 10 microswitches that look very close from ebay 10/$4 shipped

G

Grant

gee-lenahan-at-gee-mail-dot-com
Sorry, only registered users may post in this forum.

Click here to login